当前位置:首页 > 路由器 > 正文内容

交换机 DHCP 协议实验

彭淇3年前 (2017-12-29)路由器42482

交换机 DHCP 实验

    实现pc  ip地址为自动分配,并且各个pc之间能够ping通!

交换机  DHCP 协议实验 路由器 协议 第1张

二层交换机配置

Switch(config)#vlan 32
Switch(config-vlan)#exit
Switch(config)#interface f0/1
Switch(config-if)#switchport mode acc
Switch(config-if)#switchport acc vlan 30
Switch(config-if)#exit
Switch(config)#interface f0/2
Switch(config-if)#switchport mode acc
Switch(config-if)#switchport acc vlan 31
Switch(config-if)#exit
Switch(config)#interface f0/3
Switch(config-if)#switchport mode acc
Switch(config-if)#switchport acc vlan 32
Switch(config-if)#exit
Switch(config)#interface vlan 30
Switch(config-if)#ip add 172.168.30.2 255.255.255.0
Switch(config-if)#no shutdown
Switch(config-if)#exit
Switch(config)#interface vlan 31
Switch(config-if)#
Switch(config-if)#ip add 172.168.31.2 255.255.255.0
Switch(config-if)#exit
Switch(config)#interface vlan 32
Switch(config-if)#ip add 172.168.32.2 255.255.255.0
Switch(config-if)#exit
Switch(config)#interface vlan 30
Switch(config-if)#ip helper-address 172.168.30.1
Switch(config-if)#exit
Switch(config)#interface vlan 31
Switch(config-if)#ip helper-address 172.168.31.1
Switch(config-if)#exit
Switch(config)#interface vlan 32
Switch(config-if)#ip helper-address 172.168.32.1
Switch(config-if)#exit
Switch(config)#interface f0/4
Switch(config-if)#switchport mode trunk //设置串口
Switch(config-if)#switchport trunk allowed vlan all
Switch(config-if)#exit

 三层交换机配置

Switch(config)#vlan 30//划分VLAN
Switch(config-vlan)#exit
Switch(config)#vlan 31
Switch(config-vlan)#exit
Switch(config)#vlan 32
Switch(config-vlan)#exit
Switch(config)#interface f0/1
Switch(config-if)#switchport mode acc
Switch(config-if)#switchport acc vlan 30
Switch(config-if)#exit
Switch(config)#interface f0/2
Switch(config-if)#switchport mode acc
Switch(config-if)#switchport acc vlan 31
Switch(config-if)#exit
Switch(config)#interface f0/3
Switch(config-if)#switchport mode acc
Switch(config-if)#switchport acc vlan 32
Switch(config-if)#exit
Switch(config)#interface vlan 30
Switch(config-if)#ip add 172.168.30.1 255.255.255.0
Switch(config-if)#no shutdown
Switch(config-if)#exit
Switch(config)#interface vlan 31
Switch(config-if)#ip add 172.168.31.1 255.255.255.0
Switch(config-if)#no shutdown
Switch(config-if)#exit
Switch(config)#interface vlan 32
Switch(config-if)#ip add 172.168.32.1 255.255.255.0
Switch(config-if)#no shutdown
Switch(config-if)#exit
Switch(config)#service dhcp//配置DHCP
Switch(config)#ip dhcp pool p1
Switch(dhcp-config)#network 172.168.30.0 255.255.255.0
Switch(dhcp-config)#default-router 172.168.30.1
Switch(dhcp-config)#dns-server 172.168.1.1
Switch(dhcp-config)#exit
Switch(config)#ip dhcp pool p2
Switch(dhcp-config)#network 172.168.31.0 255.255.255.0//设置网段
Switch(dhcp-config)#default-router 172.168.31.1//设置网关
Switch(dhcp-config)#dns-server 172.168.1.1//设置DNS
Switch(dhcp-config)#exit
Switch(config)#ip dhcp pool p3
Switch(dhcp-config)#network 172.168.32.0 255.255.255.0
Switch(dhcp-config)#default-router 172.168.32.1
Switch(dhcp-config)#dns-server 172.168.1.1
Switch(dhcp-config)#exit
Switch(config)#interface vlan 30
Switch(config-if)#ip helper-address 172.168.30.1
Switch(config-if)#exit
Switch(config)#interface vlan 31
Switch(config-if)#ip helper-address 172.168.31.1
Switch(config-if)#exit
Switch(config)#interface vlan 32
Switch(config-if)#ip helper-address 172.168.32.1
Switch(config-if)#exit
Switch(config)#interface f0/1
Switch(config-if)#switchport mode trunk
Switch(config-if)#switchport trunk allowed vlan all
Switch(config-if)#exit
Switch(config)#router rip
Switch(config-router)#network 172.168.30.0
Switch(config-router)#network 172.168.32.0
Switch(config-router)#network 172.168.31.0
Switch(config-router)#exit
Switch(config)#service dhcp //开启DHCP协议
Switch(dhcp-config)#ip dhcp relay information trust-all

    测试:查看pc ip地址为自动分配,并且各个pc之间能够ping通。实验完成。

交换机  DHCP 协议实验 路由器 协议 第2张

交换机  DHCP 协议实验 路由器 协议 第3张

扫描二维码至手机访问

扫描二维码推送至手机端访问。

版权声明:本文由淇云博客发布,如需转载请注明出处。

转载请注明出处:https://www.pengqi.club/blog/221.html

分享给朋友:

相关文章

VMware 三种网络连接模式的详细介绍和区别

VMware 三种网络连接模式的详细介绍和区别

在使用VMware Workstation(以下简称:VMware)创建虚拟机的过程中,配置虚拟机的网络连接是非常重要的一环,当我们为虚拟机配置网络连接时,我们可以看到如下图所示的几种网络连接模式:桥...

更改了宽带密码之后就上不了网的解决办法

更改了宽带密码之后就上不了网的解决办法

大家好,今天我们来讲下,为什么更改了宽带账号密码之后就上不了网了,主要是因为现在的光纤宽带有两种上网的方式:一种是:路由模式一种是:桥接模式光猫里的路由模式和桥接模式。这里我用通俗点的文字来说明,大神...

路由器VTP协议

1、什么是VTP协议    VTP(VLAN Trunking Rrotocol):是VLAN中继协议,也被称为虚拟局域网干道协议,它是思科的私有协议。VTP允...

交换机与路由器综合实训

交换机与路由器综合实训

交换机与路由器综合实训实现各个PC之间能够互访,外网能ping通各个PC,并且各PC处于不同的VLAN中。PC规划PC0PC1PC2PC3Server 0Server 1VLAN30313233无34...

帧中继配置

帧中继配置

       实现如图所示的帧中继点到点网络配置连接和测试。搭建网络拓扑步骤1——给路由器添加串行接口模块在软件中拖出3台路由器,...

动态路由协议之rip配置详解

动态路由协议之rip配置详解

动态路由是网络中路由器之间互相通信,传递路由信息,利用收到的路由信息更新路由表的过程。它能实时地适应网络结构的变化。如果路由更新信息表明网络发生了变化,路由选择软件会重新计算路由,并发出新的路由更新信...

评论列表

JIUCAIJIUCAI
3年前 (2018-01-02)

辛苦了,谢谢分享!

彭淇 回复:
举手之劳,不用谢
3年前 (2018-01-02)

发表评论

访客

◎欢迎参与讨论,请在这里发表您的看法、交流您的观点。